Routing Guide for Professional Plan Subscribers


The Route4Me Professional Plan offers unlimited routes with unlimited stops, as well as unlimited optimizations and address book contacts for one user/driver.

The Professional Plan Guide takes you through the entire route planning process, from planning your first route to managing and updating your saved routes.


Setting the Route Parameters


When planning a route, you must carefully select each setting in order to get the best routing optimization results. To start setting the parameters, click “Plan New Route” and choose your preferred method for adding addresses, as described in our "Adding Addresses to Your Route" section.

Please visit the articles below for a step-by-step guide to setting the route parameters.


Naming Your Route


To edit the name of your route, click on the “Name” tab.



The system automatically assigns a name to each route, consisting of the date and time when it was planned. You can choose to change this name, or enter descriptive keywords, such as the name of the area you are visiting, so you can easily find it in later searches.

Setting the Schedule


Click on the “Schedule” tab.



Fill in the appropriate “Route Start Date”. Click on the calendar button, the click on the date in the calendar window. Alternatively, you can enter the date manually in the “Route Start Date” field.



Choose the route start time by clicking the clock button, then drag the cursors to indicate the hour and minute of the departure time.



You can also select the starting time to coincide with the sunrise or sunset time for your timezone. Click the button displaying a sun icon and a clock, then select “Sunrise” or “Sunset”.



You can optionally set a service time, representing the average duration it takes to service each stop on your route.



The service time can also be set individually for each stop, by uploading a spreadsheet file. The file should contain a separate column named “Time”, with corresponding service times for each address on your route.

Sharing Your Route


Click the “Sharing” tab to select who to share your route with. The email addresses you input in this field will receive notifications when the route is planned or modified, as well as the exported route attached as a .CSV file.



The email of the account owner will appear by default in the “E-mail Route” field. Enter your own email to receive a notification and detailed information about your route when it is planned or modified.

If you want to send these details to several email addresses or to more than one person, type in the email addresses separated by a comma.



Single Driver Route Optimization


Route4Me supports three different optimization types: Single Driver Route, Time Windows Team Route and Balanced Team Route.

The “Single Driver Route” optimization will include all of your stops into a single route and it will determine the best possible sequence for visiting the stops.

Choose your preferred route planning option (one-time route or recurring routing) to open the route parameters window. Click the “Optimization” tab, then select “Single Driver Route”.




Tour Types


You can choose between three different tour types:


  • End route at any address – the starting and ending points will be different and the ending point will be determined by the optimization engine.
  • End route at departure address (Roundtrip) – the route is a round trip, starting and ending at the same address.
  • End route at last address – the route ends at the last destination in your address list.

Disable Optimization


The “Disable Optimization“ option allows you to plan a route with the exact address sequence that you input into the system. Route4Me's optimization engine will not sort the addresses based on time or distance constraints.

To enable this option, you must select one of the available ways for adding addresses to your route, and then:


  1. Click the “Optimization” tab.
  2. Select the “Disable Optimization” subtab.
  3. Check the “Disable Route Optimization” box.
  4. Choose the type of route (“Roundtrip” if you want the route to end at the departure address or “End route at any address” if you want to let the system decide the optimal address sequence).



Setting the Directions Preferences


Route4Me offers turn-by-turn directions for your planned routes. To set the directions preferences, click the “Directions” tab.



You choose to navigate your route by distance, time or time with traffic. Click on the “Navigate By” drop down menu to select the most appropriate option.


  • Distance - optimizes directions for the shortest possible distance
  • Time - optimizes directions for the shortest possible time, conditioned by speed limits
  • Current Time with Traffic - optimizes directions for the shortest possible time, taking into account traffic information available when the route is planned



Next, select between “Driving” and “Walking” modes.



You can minimize or avoid highways and tolls by selecting one of the options available in the “Highways and tolls” drop down menu.

Setting the Distance Type


The “Distance” tab allows you to control route optimization speed and quality.

There are three distance types you can choose from:

  1. Drive Time Optimization - Uses actual driving time and distances; it provides the most accurate distance estimation and optimization takes more time.
  2. Straight Line Optimization - Uses straight lines to get distances; optimization is faster.
  3. Big City Optimization - Uses an estimation of distances for grid organized cities; optimization is faster.



“Drive Time Optimization” is the recommended setting for the most route planning scenarios. It usually takes a few seconds for the optimization engine to optimize a route of around 50 stops. For larger routes of more than 100 stops, the optimization might take up to a few minutes.


Adding Addresses to Your Route


Route4Me features five methods for adding addresses to a route, to accommodate different needs.

Click “Plan New Route” in the navigation panel on the left-hand side of your screen.



You can choose to add addresses to your route in five different ways: through the interactive map editor, by copying and pasting a list of addresses, by uploading a spreadsheet with your addresses from your computer or by uploading your addresses from a cloud account. Alternatively, you can scan your address list and send it to the Route4Me support department for digitization.



The Interactive Map Editor is a useful option if you’re planning a small route, with 10 stops or less. It lets you add each address manually, either by typing it in or by selecting it directly from a map.

The Copy-and-Paste option lets you add several addresses to your at once, by pasting them in from another file or software. This is a good option if you’re planning small or medium routes and you already have a list of your addresses which you can copy and paste into Route4Me.

The Upload a File and Import Data features are the recommended options for planning a route. They are the most efficient ways to add multiple addresses, by uploading or importing a spreadsheet file to Route4Me. This is the feature you should consider when planning larger routes.

The Upload Scan option allows you to scan a paper document containing your address list. The address list will be digitized by the Route4Me support department.


Interactive Map Editor


After selecting the “Interactive Map Editor” option on the home screen, set the routing parameter as described in our tutorial on “Setting the Route Parameters”, then click “Create Route and Proceed to Add Addresses”.



A new window will appear. On the left side of the window, you can manually type or paste in an address and an alias. Be sure to enter all relevant information, such as street name and number, town or city, state or country and postal code.



The first address you enter will always be your start point. As you type in your address, the system will provide an autocomplete suggestion list of geocoded destinations. The list will narrow down as you add more address information.



The address field can also be used to add contacts from your address book to your route. You can input part of the alias, first or last name associated with one of your contact and the system will include the information in the autocomplete suggestions. The alias of the contact will be displayed between brackets.



IMPORTANT: Make sure you use the autocomplete suggestions every time you include a new destination, otherwise the address will not be geocoded properly and won't be added to the route.

Route4Me also supports reverse geocoding. Instead of typing in the address, you can type in the latitude and longitude coordinates for that location. The autocomplete suggestion list will work the same as before.



When you’re done, click “Add Another Address” and repeat the same steps until you finish adding all your destinations.



The second way you can add stops to your route is by using the map on the right hand side of the screen. Navigate to your desired destination on the map, then right click on it.

Select “Add the Nearest Valid Address” to insert the nearest geocoded destination into the route (forward geocoding).

Select “Add this Exact Location” to insert the exact selected location into the route (reverse geocoding).



Copy-and-Paste


After selecting the “Copy-and-Paste” option on the home screen, set the routing parameters as described in our tutorial on "Setting the Route Parameters", then click “Create Route and Proceed to Add Addresses”.



Using the copy and paste option allows you to copy multiple addresses from another location, such as a word document, an unformatted spreadsheet or another software application, and paste them into Route4Me.



You can also insert the alias for each stop, separated from the address by a vertical bar.



Route4Me uses geocoding to get latitude and longitude coordinates for each address. Geocoding will be more accurate for complete and properly written addresses.

After the geocoding is done, the software will display a dot next to each address. If the dot is green, that means that the address is geocoded with high confidence. A yellow dot indicates that there was a small problem and the software wasn’t able to identify that precise address, but found something similar which might be correct. A red dot means that the address couldn’t be geocoded. In this case, you have to either remove it from the list or edit it.



To edit an address, roll your mouse cursor over it and click on “Edit”.



You will be able to enter the new address and click “OK” when you’re done.



On the right side of the window you will see the address map. If you need to, you can use it to fine-tune each address, simply by dragging the pin with the number for the corresponding address and dropping it to the new location.



You can also remove an address by right clicking on its pin, then selecting “Delete”.



When you're done, click on “Finish Import”. AT this point, your route will begin to optimize. The process might take anywhere from a few seconds to a few minutes, depending on the number of stops on your route.

Upload a File


The “Upload a File” feature is perfect for planning large routes. This feature allows you to upload a spreadsheet with the addresses you want to visit.

After selecting the “Upload a File” option on the home screen, set the routing parameters as described in our tutorial on "Setting the Route Parameters", then click “Create Route and Proceed to Add Addresses”.



IMPORTANT:

  • the first address in your spreadsheet will be set as the departure address
  • the spreadsheet must contain column headers designating what information is contained in that column
  • the supported file formats are: .XLS, .XLSX and .CSV (the last is the best for uploads)
  • the spreadsheet must contain more than one address


The spreadsheet you upload should contain at least two columns: the “Alias”, or name of the customer, and the “Address”, consisting of the street name and number, city, state and zip code.



You can optionally add other pre-defined and custom columns to your spreadsheet, if you need to have specific information about your destinations available when you are planning the route.

Type in the headers for the “Alias” and “Address” columns in the first row. You can alternatively split the address information into four different columns: “Address” (street name and number), “City” (name of city), “State” (name or postal abbreviation of state) and “Zip” (the zip or postal code).

Add the name of each customer or of each stop you are visiting in the “Alias” column, and their addresses in the “Address” column.

When your file is ready, upload it by clicking anywhere on the upload area.



You will see a preview of the file you uploaded.



Click on the header of any of the columns and select a new option if you need to make any changes to how the information is mapped to the system.



Click “Continue” to proceed to the final review screen.



Click “Continue to Review” to verify the addresses on Map.

Route4Me uses geocoding to get latitude and longitude coordinates for each address. Geocoding will be more accurate for complete and properly written addresses.

After the geocoding is done, the software will display a dot next to each address. If the dot is green, that means the address is geocoded with high confidence. A yellow dot indicates that there was a small problem and the software wasn’t able to identify that precise address, but found something similar which might be correct. A red dot means that the address couldn’t be geocoded. In this case, you have to either remove it from the list or edit it.



To edit an address, roll your mouse cursor over it and click on “Edit”.



You will be able to enter the new address and click “OK” when you’re done.



On the right side of the window you will see the address map. If you need to, you can use it to fine-tune each address, simply by dragging the pin with the number for the corresponding address and dropping it to the new location.



Rolling you mouse cursor over a destination will bring up detailed information about it, including the data from custom columns.



You can also remove an address by right clicking on its pin, then selecting “Delete”.



When you're done, click on “Finish Import”. At this point, your route will begin to optimize. The process might take anywhere from a few seconds to a few minutes, depending on the number of stops on your route.

Import Data


The “Import Data” feature is a functional alternative to uploading a spreadsheet file from your computer and it allows you to import your addresses from one of the supported cloud storage services: Google Drive, Dropbox and Box.net. The feature also supports imports from Xero and Quickbooks.

After selecting the “Copy-and-Paste” option on the home screen, set the routing parameters as described in our tutorial on "Setting the Route Parameters", then click “Create Route and Proceed to Add Addresses”.



Before importing the data, make sure you have it in a formatted spreadsheet, as described in our "Uploading a File" section.

Next, follow the steps below. These steps apply for Google Drive, Dropbox and Box.net file imports.


Importing Data from Google Drive


Click on the “Google Drive” tab.



Click the “Authorize” button to login to the selected service.



Select the file you want to use for the import.




Importing Data from Box.com


Click on the “Box.net” tab.



Enter your Box.com credentials, then click “Authorize”.



Click “Grant access to Box”.



Select the route spreadsheet that you want to import.




Importing Data from Dropbox


Click on the “Dropbox” tab.



Enter your Dropbox credentials, then click “Sign In”.



Select the route spreadsheet that you want to import.



After performing these actions, click the “Import Selected” and you will see a preview of the file you uploaded.



Click on the header of any of the columns and select a new option if you need to make any changes to how the information is mapped to the system.



Click “Continue” to proceed to the final review screen.



Click “Continue to Review” to verify the addresses on Map.

Route4Me uses geocoding to get latitude and longitude coordinates for each address. Geocoding will be more accurate for complete and properly written addresses.

After the geocoding is done, the software will display a dot next to each address. If the dot is green, that means the address is geocoded with high confidence. A yellow dot indicates that there was a small problem and the software wasn’t able to identify that precise address, but found something similar which might be correct. A red dot means that the address couldn’t be geocoded. In this case, you have to either remove it from the list or edit it.



To edit an address, roll your mouse cursor over it and click on “Edit”.



You will be able to enter the new address and click “OK” when you’re done.



On the right side of the window you will see the address map. If you need to, you can use it to fine-tune each address, simply by dragging the pin with the number for the corresponding address and dropping it to the new location.



Rolling you mouse cursor over a destination will bring up detailed information about it, including the data from custom columns.



You can also remove an address by right clicking on its pin, then selecting “Delete”.



When you're done, click on “Finish Import”. At this point, your route will begin to optimize. The process might take anywhere from a few seconds to a few minutes, depending on the number of stops on your route.

Upload Scan


You should consider the “Upload Scan” if you don't have your addresses in digital format or none of the other options for adding addresses is available to you.

If you choose this option, you only need to name your route and set the schedule when you set your route parameters.



Scan the file to your computer, then select it and upload it to Route4Me.



You will receive a message informing you that your request is being processed by our support department. Depending on the complexity of the route, it could take up to 48 hours for the support team to return the formatted file.




Managing Your Contacts with the Address Book


The “Address Book” helps you keep track of all your addresses and is particularly useful if you have places or customers you need to visit on a regular basis.

You can access your contacts through the “Address Book” and the “Address Book Map”. The “Address Book” lets you view your addresses in as a list as tiles, while the “Address Book Map” allows you to visualize up to 100,000 contacts on the same map.

Route4Me's “Address Book” helps you keep track of all your addresses, all the information that is important about them, their visited frequency, date when they were last visited and routed.

View the articles below for a complete description of the functionality of the Address Book and the Address Book Map.

Adding Addresses to the Address Book


You can add addresses to your address book individually, or by uploading a spreadsheet containing multiple addresses.

Click on the “Address Book”, then select “Address Book List”.



Adding Contacts One by One


To add new address to your address book, click “Add Address” in the “File” menu.



Type in your address, then select it from the autocomplete suggestion dropdown.



Under the Location tab, choose an alias and a color for the pin indicating the address on the map.



You can add additional information, such as a group the contact will be assigned to, the first and last name of your contact person, the email and phone number, by filling in the corresponding fields under the “Location Details” tab.



You can also add custom data by clicking the “Edit Custom Data” button.



Add a field name and field content for your custom data. If you want to add more than one field, click “Add One More”.



Click “Add” to finish editing your contact.



Adding Contacts in Bulk by Uploading a File


You can add multiple contacts to your address book by uploading a spreadsheet file.

Your file should contain the following columns: “Alias”, “First_Name”, “Last_Name”, “Address”, “Group”, “Email”, “Phone”.



Any additional columns you insert in your spreadsheet will be added to the custom data section of your contact.

To upload your file, click the “Upload Addresses” in the “File” menu.



Click anywhere on the upload area.



Review your addresses if necessary, then click “Add to Address Book” to complete the upload.

Viewing Contacts


Route4Me supports multiple options for viewing and sorting your contacts either as a list, or on a map.


Viewing Your Contacts in the Address Book List


To view your contacts in the Address Book List, click “Address Book” and select “Address Book List”.



The columns displayed in your Address Book List view are: the alias, the first and last name, “Phone”, “E-mail”, “Address”, “Group”, “No. of Routes”, “Last Known Visit”, “Last Known Route” and “Actions”.



Use the arrows in the column headers to sort your contacts alphabetically, ascending or descending, depending on the type of information the column contains.



You can switch between list and tile views by clicking the corresponding button in the top-right corner of your screen.



The Tile View will display the information for each contact as a separate tile.




Viewing Your Contacts on a Map


To view your contacts on a map, click on “Address Book”, then select “Address Book Map”.



The address book map is a visual tool that makes viewing and managing your contacts easier. It can give you a clearer picture about how to plan your routes.

Each of your contacts is shown as a pin on the map. When you have multiple contacts at the same address or in the same area, they will show as a blue circle indicating the number of contacts for that specific address or area.

Rolling your mouse cursor over the pin will show all available information on the respective contact.



Managing Address Details and Custom Data


To edit a contact from your Address Book, click the “Edit” button in the “Actions” column.



Edit the address name, then select it from the auto-complete suggestion menu.



Under the Location tab, you can change the alias and the color of the pin indicating the address on the map.



You can edit additional information, such as the first and last name of your contact person, the email and phone number under the “Location Details” tab.



Cusom data can be edited by clicking the “Edit Custom Data” button.



Click “Save” after you have finished editing your contact.


Color-coding Your Contacts


You can color-code groups or individual contacts in your address book by using one of the two available options: by assigning contacts to a predefined group or by using the manual color picker.


Color-coding by Assigning Contacts to a Predefined Group


The first way you to color-code your contacts is by assigning them to a specific group. The system will automatically assign the following colors if you assign your contacts to one of the predefined groups:

Green – Used for contacts in the “Active” group
Yellow – Used for contacts in the “Prospect” group
Red – Used for contacts in the “Cancelled” group
Blue – Used for everything else / unassigned contacts

To assign the contact to one of these groups, go to the address book and click “Edit” in the “Actions” column.



Under the “Location Details” tab, go to the “Group” field and type in the name of the group you want to assign the contact to.



Write “Active” for a green pin, “Prospect” for yellow pin and “Cancelled” for a red pin. Be sure to spell the name of the group precisely as indicated. Everything else you write in the group field, or even leaving it blank, will mark the address with a blue pin.



You can also do this when you upload a spreadsheet, by specifying the contact group in the “Group” column.



If you need more options, you can assign custom colors to contacts, either individually or in bulk.

To change the color for a single contact, right-click the pin in the Address Book Map, then select “Edit”.



Next, click on one of the colors available under the “Location” tab.



To assign a color for multiple contacts at once, take the following steps:

1. Click on one of the selection tools in the upper left-hand side corner of the map;

2. Click and drag to make a selection around the contacts;

3. Right-click the selected area and click the “Assign Color to Addresses”.



Chose one of the available colors, then click “Confirm” when prompted.



The color of the pin will be changed for the selected addresses.



Setting up and Managing Territories


The Address Book Map allows you to balance territories and routing personnel within user defined regions.

Territory based optimization is useful if you want to visually determine area proximity to regional office / warehouse locations and then to easily assign customers to personnel who are in the vicinity.


Creating a Territory by Manually Drawing the Borders


To draw a territory, click the “Draw New Territory” button on the right hand side of your Address Book Map screen.



Type in a name for your territory, then select the color your territory will have on the map. Click “Add” when you’re done.



Click on the map to start drawing your territory’s borders. Continue drawing your territory point-by-point by left-clicking on the map. Each click will determine the territory's borders, marked by straight lines. To complete the territory selection, either double-click on the map or connect the border lines back to the point where you initially started.



Repeat this process for each territory you want to add to your map. You can add an unlimited number of territories.



Note that you may draw overlapping territories. In this case, addresses in the overlap area will be included in both territories. This may come in useful if you need to add sub-territories to your map.



To display or hide your territories on the map, check or un-check the box next to each one.



If you need to download the addresses inside a territory to a spredsheet file, you can do so by clicking the gear icon next to the territory, then selecting “Download Territory”.



You can also view the number of addresses in each territory in the territory count section. Rolling your mouse cursor over a territory will display the exact address count for that territory.



To delete a territory from the map, click the gear icon, then select “Remove Territory”. Note that this will only delete the territory borders, not the address book contacts encompassed within that territory.



Advanced Contact Filtering


Filtering Contacts in the Address Book


Use the search bar to look for information associated to a certain contact.



The search function displays results from all the data associated to a certain contact.

The three “Display” buttons in the top right of the screen allow you to sort what addresses you can view.



  • Display All: shows all of your contacts
  • Display Routed Addresses: shows addresses that were in at least one route
  • Display Unrouted Addresses: shows addresses that were never used in a route


Filtering Contacts on the Address Book Map


Choose which addresses are displayed on the map by clicking one of the three “Show” buttons at the top right corner of the screen.



You can opt to show all your addresses, the addresses that have been routed at least once or addresses that have never been routed.

Planning a Route Using the Address Book


Planning a route with the address book is a great feature to have if you have places or customers you need to visit on a regular basis. You can use the address book to plan routes in four different ways: by selecting contacts from the address book list, by drawing a shape on the address book map, by using the “Territories” feature or by using the “Search Groups” option.


Selecting Contacts in the Address Book List


Check the boxes next to the addresses you want to add to your route.



To select all your contacts, check the box in the header.



Click “Plan Route with Selected”.




Drawing a Shape on the Address Book Map


The address book map lets you plan your routes in a visual and intuitive way.

On the top left corner of the map, you will the selection tools.



The hand tool (or stop drawing) lets you move around the map by clicking and dragging it.

The “Draw a shape” tool lets draw an irregular shape around the addresses you want to select for your route. Draw each line by clicking and releasing on the spots on the map that will be the ends of your selection.



Shapes can be modified by dragging the dots that appear on the shape's borders.



The “Draw a rectangle tool” lets you select the addresses on your map in a symmetric, rectangular shape. Drag the rectangle around the contacts you wish to select and then release to finish the selection.



The “Draw a circle” tool allows you to create and adjust the radius of a circle around a set of destinations.



Rolling your mouse cursor over the circular shape will display the total radius (in miles).



If want to change your selection, just click the “X” button and they will be automatically erased.



When you’re happy with your selection, click “Plan route with selected”.




Planning a Route With a Territory


To plan a route using the addresses within one of your territories, click the gear icon next to the territory’s name, then select “Plan Route”.




Planning a Route Using Search Groups


To plan a route using the addresses included in one of your search groups, click the gear icon in the search group header, then click “Plan Route”.




Setting the Route Parameters


After selecting your contacts from the Address Book or from the Address Book Map, type in your departure address, or select it from the list of addresses within that territory.



Proceed to setting the routing parameters to finalize planning your route.

Exporting the Address Book


You can export the contacts in your address book to a .CSV file, either from the “Address Book List” or from the “Address Book Map”.

To export your contacts from the “Address Book List”, select the contacts you want to export by clicking the checkboxes next to them, then click “Export Selected”.



If you want to export your entire address book, you should make the selection by clicking the “Select All” button that appears when a selection is made.



A contacts export using the “Address Book Map” can be performed in three steps:

  1. Choose one of the available selection tools;
  2. Draw a shape around the pins corresponding to the contacts you want to include in the export;
  3. Click “Export Selected”.



Deleting the Address Book


To delete the contacts in your address book, first select all of them by checking the box in the header.



If your address book expands over several pages, you can additionally click “Select All”.



Click “Remove Selected”.



Assigning Icons to Your Contacts


You can make certain contacts or contact groups stand out by assigning an icon, or emoji, in the Address Book Map.

To assign an icon for a single contact, right-click on the pin, then select “Edit”.



Next, click on the pin icon in the “Location” section.



Select one of the available icons by clicking on it, then click “Save” to close the “Edit Address” box.



To assign an icon for multiple contacts at once, you must:

  1. Click on one of the selection tools in the upper left-hand side corner of the map;
  2. Click and drag to make a selection around the contacts;
  3. Click the “Assign Color” button.



Click the default icon, then choose one of the available icons to replace it.



The icon will be displayed for the selected addresses.



Filtering your Contacts with Search Groups


Route4me’s advanced search engine allows you to group your contacts by making custom selections, with unlimited constraint filters. This will allow you to better manage your addresses. The “Search Groups” option can be accessed in the Address Book Map.



The “Search Groups” menu appears on the left hand side of the Address Book Map screen.



To minimize it, click the “Close” button on the sidebar.



To open it again, click the dark grey area at the middle of the sidebar.



Creating a group based on a custom selection is a three step process:


  1. Select the field to which you want to apply the search;
  2. Select the relational operator that determines the selection type;
  3. Input search text.


To start making your selection, click on the drop down field and choose the field your search will apply to.



You can opt to search in all fields, or you can restrict your search to one of the static fields (such as address, alias or email) or to one of the custom fields (relating to the custom information you uploaded into the system when you created your address book).



Next, select the proper relational operator that defines the relation between the field selection and the searched text. The options are:

  • Contains – text is present in the field as digit, a word or part of a word;
  • Doesn’t contain – text is not present in field;
  • Has word – text is present in field as a whole word;
  • Equal – contains the exact text specified;
  • Not equal – contains anything but the exact text specified;
  • Begins with – any of the words or numbers in the field begin with a certain letter or group of letters or digits;
  • Ends with – any of the words or numbers in the field end with a certain letter or group of letters or digits;
  • Is empty – field does not contain any information;
  • Is not empty – field contains any information.



Finally, you need to input the search text.



For example, if you would like to display only addresses within a specific ZIP code, you would select the “Address” field, then select “contains” as the relational operator and finally type in the ZIP code as your search text. The selection will appear on the address book map whenever the search group is checked.



After inputting the search parameters, you can assign a color to the group.



To assign a name to the group, click on the header and type it in.



You can refine your search by adding rules and sub-groups to a search group. A sub-group is a group of rules that acts as one rule in relation with other rules. Click “Add rule” to add a new filter.



Go through the same steps as before and select the field, the relational operator and use the rule to refine the selection.

Additionally, you need to establish the type of relation between the rules or groups by selecting the proper logical operator. “AND” will cumulate the rules and only display contacts that meet both criteria. “OR” will display contacts that meet either of the input criteria.



If you want to add a new group based on new filtering criteria, click the “+ Add Group” button



You can also open the search group in a separate window. Roll your mouse cursor over the name of the search group, then click the “expand” icon that appears next to the gear icon.



A new window will appear, where you can perform the same actions detailed above in a larger setting.




Editing and Managing your Existing Routes


Rout4Me allows you to edit your routes after having planned them. Please visit the articles below to find out how you can edit and manage your existing routes.

Adding Addresses to an Existing Route


Route4Me allows you to add addresses at any time after planning a route. The addresses can be added using the “insert” menu or using the route map.

Click “Routes”, then “Routes List”.



Click the gear icon next to the route you want to edit, then select “Open Route” to access the “Route Editor”.




Adding Destinations Using the Insert Menu


Click “Insert”, then select one of the options for adding addresses: add addresses by typing them in, by copying and pasting, by uploading a file with multiple addresses or by importing data from a one of the supported file hosting accounts.



To find out more about adding addresses, please visit our section on "Adding Addresses to your Route".


Adding Destinations Using the Route Map


Right-click on the map on the exact location of the destination you want to add to bring up a pop-up menu.



There are six options you can choose from:

  • Add this Address after Last Stop - adds the nearest geocoded address after the last stop on the route
  • Add this Address after Last Visited Stop - adds the nearest geocoded address after the last visited stop, on ongoing routes
  • Add this Address at Optimal Position - adds the nearest geocoded address at the optimal position, based on time and distance constraints
  • Add this Exact Location After Last Stop - adds the exact location selected on the map after the last stop on the route
  • Add this Address after Last Visited Stop - adds the exact location on the map after the last visited stop, on ongoing routes
  • Add this Exact Location Optimal Position - adds the exact location selected on the map at the optimal position, based on time and distance constraints


Adding Destinations With Rapid Address Input


The rapid address input option allows you to add stops with additional data to a route. The available additional data fields are:

  • Alias
  • First Name
  • Last Name
  • Email
  • Phone
  • City
  • Zip
  • Order No
  • Cost
  • Revenue
  • Cube
  • Pieces
  • Weight
  • Service Time

Click “Insert” → “Quick Insert Address” or use the Ctrl+I keyboard shortcut to open the rapid address input window.



Input the address corresponding to the stop you want to add to the route. Select one of the available suggestions in the auto-complete list to make sure your address is geocoded properly.



Press “Tab” or “Enter” on your keyboard if you want to add additional fields to the stop. Select one of the available fields, then input the value corresponding to the information you want to add for that stop. Repeat the same process for the all additional fields you need to add.



When you’re done adding the information associated with the stop click either “Save” to close the rapid input window or “Save + New” to add a new stop.



Deleting Addresses from an Existing Route


Go to the “Routes List”.



Click the gear icon next to the route you want to edit, then select “Open Route”.



Click on the “X” symbol next to the address you want to delete.



Select one of the available cancellation reasons.



Click “Confirm” to remove the address from your route.



Changing the Order of Addresses



Dragging and Dropping a Destination Anywhere Within a Route


Go to “Routes List”.



Click the gear icon next to the route you want to edit, then select “Open Route”.



Click and hold on the address you want to move, then drag and drop it to the new location within the route.



Move it to the top of the list if you want to set it as the new departure address.


Setting a Destination as the First or Last on the Route


To set a destination as the first or last on the route, right-click on it in the list on the left-hand side of the route editor, then select the desired action.



If your route is a round-trip, both of these actions will have the same effect. The starting and ending destination will be replaced by the selected address.


Duplicating a Stop


Any destination on a planned route can be duplicated. In the route editor, right-click on the destination, then select one of the available options:

  • Duplicate this Stop - this will duplicate the destination as a general stop (no stop type assigned)
  • Duplicate this Stop as… - rolling your mouse cursor over this option will bring up a pop-up menu with the available address stop types: pickup, delivery, break, meet-up or visit. Click on an option in the list to assign it to the duplicate stop.



The duplicated stop will be inserted in the route just after the original stop. All the information associated with the information will be duplicated, including the address, alias and custom data.



Editing Address Details and Custom Data in the Route Editor


When viewing a planned route in the Route Editor, you can access the details for an addresses by clicking on it in the address list.




Address Information


The “Address Information” section allows you to view and edit address data associated with a stop. This section includes the following fields:

  • Address (editable field) – the full address associated with the selected stop; modifying data in this field will change the location of the stop. You can also input latitude and longitude coordinates instead of street, city and state.
  • Alias (editable field) – the alias / name associated with the stop.
  • Lat, Lng (read-only) – the geocoded latitude and longitude coordinates for the stop.
  • Address Stop Type (multiple choice drop-down) – the stop type drop-down list has several predefined values: Delivery, Pickup, Break, Meetup, Service, Visit, Drive By. Stop types help set the right expectations for drivers while they’re out in the field, and they also help dispatchers get more predictability regarding the route structure.




Address Visit Details


The “Address Visit Details” section provides details regarding the operational status of each stop. It consists of four fields:

  • Marked as Visited (check-box) – the timestamp (MM/DD/YYYY HH:SS) for when the driver manually marked the address as visited on a mobile device. Addresses can also be marked as visited in the route editor by clicking the corresponding checkbox.
  • Marked as Departed (check-box) – the timestamp (MM/DD/YYYY HH:SS) for when the driver / dispatcher manually marked the address as departed.
  • Detected as Visited (read-only) – the timestamp (MM/DD/YYYY HH:SS) for when the system automatically detected the driver as entering the geofenced area around the address.
  • Detected as Departed (read-only) – the timestamp ((MM/DD/YYYY HH:SS) for when the system automatically detected the driver as entering the geofenced area.



Hovering the mouse cursor over a timestamp in any of the four fields will highlight the recorded location of the driver when the address was marked / detected as visited / departed on the route map.




Order Data


The “Order” section allows you to view and edit relevant information regarding the order delivered to the address.

  • Order No (editable field) – the order number.
  • Order Cost (editable field) – the total cost for the order(s) delivered to the address.
  • Cube (editable field) – the cubic volume of the order(s).
  • Invoice No (editable field) – the invoice number.
  • Pieces (editable field) – the number of pieces included in the order.
  • Reference No (editable field) – the internal reference number associated with the order.
  • Revenue (editable field) – total revenue generated by the order.
  • Weight (editable field) – total weight of the order.
  • Priority (editable field) – the order priority; this field can change the sequence of addresses in the route (lower priority orders will be visited first)
  • Tracking Number (external link) – the customer tracking number which allows customers to see the location of the driver in real time.



The values in some fields (Order Cost, Cube, Pieces, Revenue, Weight, Priority) can be applied to all other stops on the route by clicking the gear icon → “Apply to All”.




Customer Information


In the “Customer Information” section you can view or edit the personal details of a customer.

  • First Name (editable field) – the first name of the customer.
  • Last Name (editable field) – the last name of the customer.
  • E-mail (editable field) – the customer’s e-mail address. This field is required for sending e-mail notifications with the “Real-Time Tracking for Customers” module.
  • Phone (editable field) – the customer’s phone number. This field is required for sending SMS notifications with the “Real-Time Tracking for Customers” module.
  • Customer PO (editable field) – the customer purchase order number.
  • Group (editable field) – the (optional) group to which the customer is assigned.




Time Data


The “Time” section displays the time window constraints, service time and time on site

  • Time Window Start (editable field) – the start time for the first time window interval in which the address can be visited (D, HH:MM)
  • Time Window End - the end time for the first time window interval in which the address can be visited (D, HH:MM)
  • Time Window Start 2 (editable field) – the start time for the second time window interval in which the address can be visited (D, HH:MM)
  • Time Window End 2 (editable field) – the end time for the second time window interval in which the address can be visited (D, HH:MM)
  • Service Time (editable field) – the estimated amount of time for servicing the address (HH:MM:SS)
  • Marked Time on Site (read-only) – the time difference between the “Mark as Visited” and “Marked as Departed” fields
  • Detected Time on Site (read-only) – the time difference between the “Detected as Visited“ and “Detected as Departed” fields




Projected Estimated Arrival Times


The “Projected Estimated Arrival Times” are the estimated times when the driver is supposed to arrive and depart the address. They are calculated when the route is planned, based on route parameters such as service time and estimated driving time.

  • Projected Estimated Arrival Time (read-only) – the approximate arrival time, not taking into account external factors such as traffic and driver check-ins.
  • Projected Estimated Departure Time (read-only) – the approximate departure time, taking into account the service time for the address but not taking into account external factors.




Dynamic Estimated Arrival Times


The “Dynamic Estimated Arrival Times” are dynamically updated when a driver is running a route, based on current traffic and field activities such as visitation and departure check-ins.

IMPORTANT: The dynamic estimated arrival times are updated by the driver’s manual check-ins (Marked as Visited / Departed), not by the automatic geofencing triggers (Detected as Visited / Departed).

  • Dynamic Estimated Arrival Time (read-only) – the dynamically updated arrival time, which takes into account external factors such as traffic and driver check-ins.
  • Dynamic Estimated Departure Time (read-only) – the dynamically updated departure time, which takes into account the service time for the address and external factors.




Custom Data


The “Custom Data” section displays all of your custom fields and their associated values. All custom data fields can be edited and their values applied to all other addresses on the route (Gear Icon → “Apply to All”).



To add a new custom data field, scroll to the top of the address menu and click the “Add Custom Data Button”.



Type in the name of the field and its value, then click “Add Custom Data”.



To delete a custom data field, click the gear icon → “Delete”.



Changing Route Settings


You can change the settings of a planned route by clicking “Edit” → “Route Settings”.



Here you can review and modify all the route parameters you set when you initially planned the route:

  • the route name
  • the route schedule and service time
  • the optimization type
  • type of directions
  • the optimization quality

After making the necessary changes, click “Update Route Settings”.



Re-optimizing a Route


After making changes to a planned route, you can re-optimize it to make sure you get the best address sequence.

When viewing a route, click the “Route” button, then select “Re-optimize this route”.



Reversing a Route


The route reversal engine allows you to reverse the order of all addresses in a route. If your route is not round trip, then the start and end addresses will also be reversed.

To reverse a route, you first need to open it. Click “Route”, then select “Reverse this Route”.



Refreshing the Directions for a Route


Whenever you make changes to a route, such as adding a new destination, deleting an existing destination or reversing the address order, the map will display those changes in real time. However, the turn-by-turn directions for the route need to be refreshed manually to reflect the latest changes.

To refresh the directions for a route, click “Route” and select “Refresh Directions”.


Renaming a Route


Planned routes can be renamed inside the “Route Editor” and also in the “Routes List”.

To rename a route from the route editor you must:


1. Click on “Edit”;
2. Select “Route Settings”;



3. Type in the new route name;
4. Click “Update Route Settings”.



You can also rename a route in the “Routes List”.


1. Click on the gear icon next to the route;
2. Click “Rename Route”



3. Type in the new route name;
4. Click “Rename”



Customizing the Map Settings



Map Styles


The route editor supports two different map styles: “Map View” and “Matrix View”.



There are two styles available for the “Map View”: “Satellite” and “Map”.



Use the buttons at the top right corner of your map to select the map mode.

The default view is the “Map” style in the “Map View”.



You can view a close-up of each location by clicking the “Matrix” button. The locations on the route will be displayed in grid.



The “Satellite” style of the “Map View” provides a satellite view of the route region.




Map Layers


The “Map Settings” allow you to add layers to your map and to bring up additional information about your route.

The driving lines are checked by default. You should keep them on your map if you want to have a visual representation of the turn-by-turn directions for your route.



Un-checking the driving lines will display the distance between stops in a beeline. This view is also available if you check the “Original Route” box.



Check the “Traffic” box for a view of local traffic.



Checking the “Address Book” option will bring up all of your address book contacts on your route map. If you have several contacts that are very close together, you can check the “Clustering” box to display those addresses as a single cluster, rather than individual pins.



You can also bring up your defined territories by checking the corresponding box.



If you have any avoidance zones set for the routing area, you can check the “Avoidance Zone” box to display them on the route map.



To display the geofenced area associated with each address, check the “Geofences” box.



You can open the driving directions on the right side of your map.



You can also view the activity feed for that route.



To display the destinations which have a note associated with them, check the “Notes” box.



Finally, to the display the estimated arrival times for each destination, check the “ETA's” box.



Note that you can bring up multiple layers at once, depending on what information is relevant for your routing purposes.




Weather Layers


“Business” and plan subscribers and up can view multiple read-only, real-time weather layers on their route map. The layers display the weather conditions for a specific area. Check the “Current Weather” box to view all available options and to display the temperatures for selected areas on the map.



The following weather layers are available:

- Radar;


- Satellite;



- Winds;



- Storm reports;



- Snow depth;



- Temperature.




Managing your Planned Routes


Route4Me provides advanced route management options which allow you to constantly keep track of your routing activity.

Viewing Multiple Routes on the Routes Map


The “Routes Map” lets you view multiple routes on a single map, providing solutions for quickly modifying addresses between routes. This function is ideal for assigning an address to another route, when it can't be visited as initially planned.

Click “Routes”, then select “Routes Map”.



This will take you to the Multiple Routes Map view. Select the routes you want to view on the same map by checking them. Each route you select will be displayed in a different color on the map, on the right-hand side of your screen.



The map also displays useful information, such as the total distance and travel time for the selected routes.



At the bottom of your screen, you’ll be able to see your routes timeline. Here addresses are displayed linearly by date and hour of the planned visit.




Moving Stops between Routes


You can use the timeline for moving a stop from one route to another. When you want to move a stop, simply select the pin corresponding to that address in the timeline and drag it to the other route’s portion of the timeline. The change will determine automatic push notifications to both drivers involved, informing them that the route has been updated.



The changes will be made to the route instantly and you’ll be able to view them on your map.

You are also able to operate other changes to your routes by right-clicking on a stop in the timeline, then choosing the desired action.



Comparing Multiple Routes Side-by-Side Simultaneously


You can bring up to 10 routes side by side and compare them.

  1. In the “Routes List”, check the boxes next to the routes you want to include in the comparison;
  2. Click “File”;
  3. Select “Compare Selected Routes”



This will display detailed information about each route, side-by-side.



You can edit the start date and time for each route.



You can also merge all routes together. Scroll all the way to the bottom of the screen, the click “Merge These Routes”.

Viewing the Route Matrix


You can get an overview of your routing progress by viewing the route matrices for multiple routes at the same time.

  1. In the “Routes List”, select the routes for which you want to display the matrix (optional);
  2. Click “View”;
  3. Roll your mouse cursor over “Operation Matrix”;
  4. Select “With Routes scheduled for Today” to only display the routes for that day, or “With Selected Routes” to only display the routes in your selection



The destinations in the matrix are color-coded. A legend detailing the color codes is available at the bottom of the screen.



You are able to see, at a glance, which destinations are visited ahead of schedule (displayed in green), which ones are on schedule (displayed in yellow) and the ones which fell behind schedule (in red). If a route has not yet started, the destinations will be greyed out.



Roll your mouse cursor over any stop to bring up the details for that stop.



For additional actions relating to one of the routes in the matrix, click the gear icon, then select your preferred action.



Merging Multiple Routes at the Same Time


You can merge multiple routes together with Route4Me's “Merge” function.

  1. In the “Routes List”, select the routes you want to merge by checking the corresponding boxes;
  2. Click “File”;
  3. Select “Merge Selected into New Route”.



This will bring up a new window.

  1. Type in the departure address for the new merged route;
  2. Click on the correct address in the suggestion list;
  3. Choose whether you want to remove the origin destination addresses in the sub-routes by checking or un-checking the “Remove Sub-Route Origin Addresses” box;
  4. Click “Apply”.



The merged route will appear in your route list.



Deleting Routes


To delete a route, you need to take the following steps:

  1. In the “Routes List”, check the box next to the route(s) you want to delete;
  2. Click “Edit”;
  3. Select “Remove Routes”



Click “Confirm” when prompted.



Alternatively, you can:

  1. Click the gear icon next to a route.
  2. Select “Remove Route”.



Duplicating Routes


If you want to re-use a route without modifying it, you can opt to duplicate it.

  1. In the “Routes List”, click the gear icon next to the route you want to duplicate.
  2. Select “Duplicate”.



When you duplicate a route, only the origin address and all the destinations on the route are cloned into the duplicate route.

Using the Real-Time Search Engine


Route4Me's real-time search engine provides a powerful solution for helping you find specific information inside your routes. It is activated through the universal search bar located at the top of the “View Routes”, “View Multiple Routes”, “Address Book”, “Address Book Map” and “Route Editor” screens.



The search bar can be used on multiple screens in the software and has different behavior depending on the screen where it is used.


Searching Within your Route Lists


On the “View Routes” and “View Multiple Routes” screens, the search applies to the following type of data:

  • Route Name
  • Alias
  • Address (full or truncated)
  • First Name
  • Last Name
  • Email
  • Phone Number
  • Custom Data
  • Route Notes

Using the search bar on any of these screens will bring up the routes that contain the requested information in any of the specified fields.




Searching Within your Address Book Contacts


On the “Address Book” and “ Address Book Map” screens, the search engine applies to the following fields:

  • Alias
  • Address
  • First Name
  • Last Name
  • Email
  • Phone Number
  • Custom Data




Searching Within an Individual Route


In your “Route Editor”, the search applies to the following type of data:

  • Route Name
  • Alias
  • Address (full or truncated)
  • First Name
  • Last Name
  • Email
  • Phone Number
  • Custom Data
  • Route Notes

When searching inside the route editor, the search engine will:

  1. Display an autocomplete list of addresses that contain the searched information;
  2. Highlight the addresses on the map, by displaying a yellow circle around them



For advanced filters and searching options inside the Address Book Map, please visit our article on filtering contacts using search groups.